My Sonoff device is...
 
Notifications
Clear all

My Sonoff device is paired successfully but remains offline under my eWelink app

   RSS

0
Topic starter

I have completely followed the user manual for pairing my Sonoff device with my eWelink app, it gets added in successfully but always remains offline.

2 Answers
0

Sonoff device are very good at hardware level with poor software / technical support. To enjoy a hassle free user experience, upgrade your Sonoff devices to Sonoff Tasmota opensource firmware and control your device using either Yeti Smart Phone App or Domoticz Local Control Dashboard.


Please check and ensure the key points given below:

  • Your Phone and Sonoff must use same WiFi internet connection during pairing, once paired then you can use any internet connection such as WiFi / Mobile Data Network to control your Sonoff device.
  • If you are using dual-band WiFi (2.4 Ghz / 5Ghz), change the band to 2.4Ghz because Sonoff is a 2.4Ghz device and does not support 5Ghz)
  • Your mobile data must be OFF during pairing the Sonoff.
  • Also turn the “Switch to Mobile Data” option OFF under your Smart Phone WiFi Network Settings.
  • Check if you have applied some network usage restriction such as deny background data usage, under your Smart Phone Network settings.
  • If you are using any VPN services, shut these service OFF prior pairing the Sonoff.
  • Check your router’s firewall to allow the connections.
  • Sonoff devices may not work with WiFi extender, connect directly with your router.
  • In some areas, 4G services are poor and may result in failure to register a device to a user account, Change your network to 3G only for successful registration of Sonoff device with your eWelink account.
  • For more information visit Sonoff Smart Home FAQs or Sonoff Devices Offline Troubleshooting or Device offline.

If you are following all the key points mentioned above, and still facing the issue, Troubleshoot according to the instructions given below;

Ping the Itead Servers for availability, In your Windows PC press;

  • Windows key + R, type ping api.coolkit.cc -t and click OK.
  • Windows key + R, type ping cn-long.coolkit.cc -t and click OK.
  • Windows key + R, type ping cn-api.coolkit.cc -t and click OK.

If you see any Request timed out. error then it means there is some problem with your internet connection. Add the following DNS addresses under DHCP settings of your router (Follow your router’s guide) and ping the above mentioned servers again.

119.29.29.29
223.5.5.5
223.6.6.6

If you can ping the above mentioned servers and there is no Request timed out  error appears, then follow the instructions given below;

  1. Delete the device from your eWelink app.
  2. Turn your cell phone’s airplane mode ON.
  3. Turn your cell phone’s WiFi ON.
  4. Restart your cell phone.
  5. Shutdown your Sonoff device for at least 10-20 seconds (Cut off the power lines).
  6. Turn the Sonoff device ON after 10-20 seconds and press the pairing button for 8 seconds.
  7. Release the pairing button and press it again for 8 seconds.
  8. Now your Sonoff device will go under pairing mode (LED will blink continuously).
  9. Open the eWelink app and press the + button to pair your Sonoff device.
  10. If the firmware of your sonoff device is 1.6.0 or higher then you must select Quick Pairing Mode(TOUCH) icon in adding process.
  11. If the firmware of your sonoff device is lower than 1.6.0 then select Compatible Pairing Mode(AP) in adding process.
  12. Provide the correct WiFi credentials such as SSID & Password.
  13. Wait few seconds and your device will be added to your account.
  14. After successful pairing, Sonoff device may take a minute or half to become online under your Ewelink app.

If you have followed the above instructions carefully and still device is showing offline or continuously being OFFLINE and ONLINE then swap the Line (L) and Neutral (N) wires to Sonoff Line (L) and Neutral (N) terminals (Sometimes user may connect the hot wire to neutral terminals of Sonoff and vice versa).


In case you are still unfortunate to get your Sonoff online, check your device if it is faulty by adopting the following instructions.

  1. Shutdown your Sonoff device for at least 10-20 seconds.
  2. Turn the Sonoff device on after 10-20 seconds and press the pairing button for 8 seconds.
  3. Release the pairing button and press it again for 8 seconds.
  4. Now your Sonoff device will go under pairing mode.
  5. Navigate to WiFi settings of your cell phone and search for a new access point starting with “ITEAD”.
  6. Connect to this access point by providing a password “12345678” (without quotes).
  7. Once connected, open  http://10.10.7.1/device  in your mobile phone web browser.
  8. if you receive the feedback as shown below, then your device is not faulty and itead ports 443, 8080, 8081  might be blocked by your internet service provider.
{
  "deviceid":"10000xxxxx",
  "apikey":"xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx",
  "accept":"post"
}

Contact your internet service provider and ask the operator to parse these domains: cn-long.coolkit.cc, cn-api.coolkit.cc, and api.coolkit.cc .

0

I've bought a Sonoff POW on 22 Nov 2017 on ebay at $9.49.
Since then I never attached to power. Yesterday I tried to set it up.
On the device PCB, there is a writing: Sonoff POW    Ver 2.0
I used the latest eWeLink Android app (4.0.3 (22 Apr 2020)) to try to connect with, as I'm using it for the other 5 Sonoff RF device I'm using since a while. No success at all.
The device hasn't got quick pairing and compatibility mode. It has only one mode, where the button need to press at least 7 secs, and the led blink fast (about two blinks / sec).
I've tried the Coolkit POW Fix tool, with some success. It successfully paired, but after never connected to the server. The standby led blinking changed to two fast blinks, then 1 sec pause. Meaning connected to the Wifi, but to the server not.
I had an idea. Uninstalled the latest eWeLink app from my phone, downloaded and installed the 3.7.0 (22 May 2019) apk of eWeLink app from [link removed].
With this version of the app I can successfully paired the device and connected to the server. The device comes online in the app, I can control it through the app. Next I updated the POW firmware to the latest (from 2.0.2 to 2.6.1), and then updated the eWeLink app to the latest. Now everithing works as expected.

This post was modified 12 months ago by Support Team

Your Answer

Author Name

Author Email

Your question *

 
Preview 0 Revisions Saved
Share: